Active Directory Installation Wizard Conflict with the Service Filter Drivers (A039)


This applies to LiveVault Online Backup Service Agent computers running one of the following:

  • Windows 2000 Server or Advanced Server

  • Windows Server 2003


Symptoms

If you run the Microsoft Active Directory Installation Wizard (Dcpromo.exe) on a LiveVault Online Backup Service Agent computer (for example, to promote a member server to a domain controller), the operation may fail and you may see the following error:

Overlapped I/O operation is in progress.

You will also see the following error message in the Dcpromo.log file:

[ERROR] Failed to create system volume path (997)

Where error 997 maps to "Overlapped I/O operation is in progress."

Cause

For details about this problem, see the Microsoft Knowledge Base article Q295712.

Resolution

To run the Microsoft Active Directory Installation Wizard on a LiveVault Online Backup Service Agent computer, follow these steps:

  1. Disable the LiveVault Online Backup Service filter drivers:

    1. On the Desktop, right-click My Computer.

    2. Click Manage.

    3. Click Device Manager.

    4. On the menu bar, click View then click Show Hidden Devices.

    5. Expand Non-Plug and Play Drivers.

      The three LiveVault Online Backup Service filter drivers are listed:

      • LiveVault Corporation Filter

      • LiveVault Corporation Journal

      • LiveVault Corporation Recognizer

    6. Right-click on one of these filter drivers, and click Disable.

    7. When prompted to confirm the disable request, click Yes.

    8. When prompted to restart the computer, click No.

    9. Repeat steps f-h for each of the LiveVault Online Backup Service filter drivers, but after disabling the third filter driver click Yes to restart the computer.

    Note: When you restart the computer while the LiveVault Online Backup Service filter drivers are disabled, the following error is logged:

    The service failed to initialize. : Initialization failed. : Cannot communicate with the filter drivers - (NT error The system cannot find the file specified.)

    This error is benign and can be ignored.

  2. Run the Active Directory Installation Wizard to perform the desired operation.

  3. Enable the LiveVault Online Backup Service filter drivers:

    1. On the Desktop, right-click My Computer.

    2. Click Manage.

    3. Click Device Manager.

    4. On the menu bar, click View then click Show Hidden Devices.

    5. Expand Non-Plug and Play Drivers.

      The three LiveVault Online Backup Service filter drivers are listed:

      • LiveVault Corporation Filter

      • LiveVault Corporation Journal

      • LiveVault Corporation Recognizer

    6. Right-click on one of these filter drivers, and click Enable.

    7. When prompted to restart the computer, click No.

    8. Repeat steps f-g for each of the LiveVault Online Backup Service filter drivers, but after enabling the third filter driver click Yes to restart the computer.