Active Directory Installation Wizard Conflict with the Service Filter Drivers (A039)
This applies to LiveVault Online Backup Service Agent computers running one of
the following:
Symptoms
If you run the Microsoft Active Directory Installation Wizard (Dcpromo.exe) on a LiveVault Online Backup Service Agent computer (for example, to
promote a member server to a domain controller), the operation may fail and you may
see the following
error:
Overlapped I/O operation is in progress.
You will also see the following error
message in the Dcpromo.log file:
[ERROR] Failed to create system
volume path (997)
Where error 997 maps to "Overlapped
I/O operation is in progress."
Cause
For details about this problem, see the Microsoft Knowledge Base article
Q295712.
Resolution
To run the Microsoft Active Directory Installation Wizard on a LiveVault Online Backup Service
Agent computer, follow these steps:
Disable the LiveVault Online Backup Service filter drivers:
On the Desktop, right-click My Computer.
Click Manage.
Click Device Manager.
On the menu bar, click View then click
Show Hidden
Devices.
Expand Non-Plug and Play Drivers. The three
LiveVault Online Backup Service filter drivers are listed:
LiveVault Corporation Filter
LiveVault Corporation Journal
LiveVault Corporation Recognizer
Right-click on one of these filter drivers, and
click Disable.
When prompted to confirm the disable request, click
Yes.
When prompted to restart the computer, click
No.
Repeat steps f-h for each of the LiveVault Online Backup Service
filter drivers, but after disabling the third filter
driver click Yes to restart the computer.
Note: When you restart the computer while the
LiveVault Online Backup Service filter drivers are disabled, the following error
is logged:
The service failed to initialize. : Initialization
failed. : Cannot communicate with the filter drivers - (NT
error The system cannot find the file specified.)
This error is benign and can be ignored.
Run the Active Directory Installation Wizard
to perform the desired operation.
Enable the LiveVault Online Backup Service filter drivers:
On the Desktop, right-click My Computer.
Click Manage.
Click Device Manager.
On the menu bar, click View then click
Show Hidden
Devices.
Expand Non-Plug and Play Drivers. The three
LiveVault Online Backup Service filter drivers are listed:
LiveVault Corporation Filter
LiveVault Corporation Journal
LiveVault Corporation Recognizer
Right-click on one of these filter drivers, and
click Enable.
When prompted to restart the computer, click
No.
Repeat steps f-g for each of the LiveVault Online Backup Service
filter drivers, but after enabling the third filter
driver click Yes to restart the computer.
|